Thursday, May 17, 2012

Lucky Patcher v1.5.1 Apk Android App

Requirements: Android 2.1+, Rooted devices
Overview: You can use this patcher to break some apps' Android Market License Verification or other Verifications.

 Recent changes:
 Version 1.5.1
 ~ Updated Korean translation;
 ~ Error in "Patch on Reboot" fixed;
 ~ Force close in autoupdate fixed.

Download Instructions:


Post a Comment

© 2011 Apk Apps And Games Download